воскресенье, 10 апреля 2011 г.

Изучаем азы программирования

Источник: http://www.piktomir.ru/

ПиктоМир - младший брат КуМира, отдельно распространяемая, свободно распространяемая программная система для изучения азов программирования дошкольниками и младшими школьниками. ПиктоМир позволяет ребенку "собрать" из пиктограмм на экране компьютера несложную программу, управляющую виртуальным исполнителем-роботом. ПиктоМир в первую очередь ориентирован на дошкольников, еще не умеющих писать или на младшеклассников, не очень любящих писать. При желании, ПиктоМир-программу можно сохранить в КуМире и продолжить работу над ней в КуМире.
использовать Робот_Вертун

алг Главный алгоритм
нач
. нц пока клетка закрашена
. . А
. . вперед
. кц
кон

алг А
нач
. если впереди стена то
. . повернуть налево
. . иначе выход 
. все
кон

Комментариев нет:

Отправить комментарий

 
Наверх страницы